aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.28/003-adm5120_switch.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
commit7e4bc7d49177e6f53af7ed505814f0de0c882424 (patch)
tree6a481ec2a31410680efec3ade58735a22226a14c /target/linux/adm5120/patches-2.6.28/003-adm5120_switch.patch
parent37bf4d46cc5206bbaaaf746124e9a4ed3ea0876e (diff)
downloadupstream-7e4bc7d49177e6f53af7ed505814f0de0c882424.tar.gz
upstream-7e4bc7d49177e6f53af7ed505814f0de0c882424.tar.bz2
upstream-7e4bc7d49177e6f53af7ed505814f0de0c882424.zip
[adm5120] preliminary support for 2.6.28 (based on the patches by Alexandros C. Couloumbis)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14189 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.28/003-adm5120_switch.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.28/003-adm5120_switch.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.28/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.28/003-adm5120_switch.patch
new file mode 100644
index 0000000000..1359078aaf
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.28/003-adm5120_switch.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -602,6 +602,10 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config ADM5120_ENET
++ tristate "ADM5120 Ethernet switch support"
++ depends on ADM5120
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -191,6 +191,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+ # This is also a 82596 and should probably be merged
+ obj-$(CONFIG_LP486E) += lp486e.o
+
++obj-$(CONFIG_ADM5120_ENET) += adm5120sw.o
+ obj-$(CONFIG_ETH16I) += eth16i.o
+ obj-$(CONFIG_ZORRO8390) += zorro8390.o
+ obj-$(CONFIG_HPLANCE) += hplance.o 7990.o