aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
commit7e4bc7d49177e6f53af7ed505814f0de0c882424 (patch)
tree6a481ec2a31410680efec3ade58735a22226a14c /target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch
parent37bf4d46cc5206bbaaaf746124e9a4ed3ea0876e (diff)
downloadupstream-7e4bc7d49177e6f53af7ed505814f0de0c882424.tar.gz
upstream-7e4bc7d49177e6f53af7ed505814f0de0c882424.tar.bz2
upstream-7e4bc7d49177e6f53af7ed505814f0de0c882424.zip
[adm5120] preliminary support for 2.6.28 (based on the patches by Alexandros C. Couloumbis)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14189 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch b/target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch
new file mode 100644
index 0000000000..16470704a6
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch
@@ -0,0 +1,22 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -540,5 +540,9 @@ config MTD_PLATRAM
+
+ This selection automatically selects the map_ram driver.
+
++config MTD_ADM5120
++ tristate "Map driver for ADM5120 based boards"
++ depends on ADM5120
++
+ endmenu
+
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -42,6 +42,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
+ obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
+ obj-$(CONFIG_MTD_PCI) += pci.o
+ obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
++obj-$(CONFIG_MTD_ADM5120) += adm5120-flash.o
+ obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
+ obj-$(CONFIG_MTD_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_IMPA7) += impa7.o