aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-08-07 13:50:02 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-08-07 13:50:02 +0000
commit42c075c401b6a165b6fde371c0a81d894b9bf13f (patch)
tree8a9c734b41c7fefe6035e0c092a559ae30a2b0df /target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch
parent10dd170af6d9730ff2107abd6def362ddf74a4b9 (diff)
downloadupstream-42c075c401b6a165b6fde371c0a81d894b9bf13f.tar.gz
upstream-42c075c401b6a165b6fde371c0a81d894b9bf13f.tar.bz2
upstream-42c075c401b6a165b6fde371c0a81d894b9bf13f.zip
[adm5120] add 2.6.26 specific files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12239 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch
index 341d8020e8..a0d363a9b1 100644
--- a/target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch
+++ b/target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch
@@ -1,12 +1,12 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -215,4 +215,12 @@
- tristate "LED Morse Trigger"
- depends on LEDS_TRIGGERS
+@@ -207,4 +207,12 @@
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
-+ depends on LEDS_TRIGGERS && LEDS_ADM5120
++ depends on LEDS_TRIGGERS && ADM5120
+ help
+ This allows LEDs to be controlled by the port states of
+ the ADM5120 built-in Ethernet Switch
@@ -16,7 +16,7 @@
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -30,3 +30,4 @@
- obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o