aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.25/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-02 08:52:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-02 08:52:37 +0000
commitaaac1064de71c495d284b981d83f70d3bd445826 (patch)
tree7c16764a4adcbec9b238e77d43c50d7830d5a82e /target/linux/adm5120/patches-2.6.25/007-adm5120_pci.patch
parent9b7ea0451a082c8e9598f639c245f2ab9233a9fb (diff)
downloadupstream-aaac1064de71c495d284b981d83f70d3bd445826.tar.gz
upstream-aaac1064de71c495d284b981d83f70d3bd445826.tar.bz2
upstream-aaac1064de71c495d284b981d83f70d3bd445826.zip
add initial support for 2.6.25
SVN-Revision: 11005
Diffstat (limited to 'target/linux/adm5120/patches-2.6.25/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.25/007-adm5120_pci.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.25/007-adm5120_pci.patch b/target/linux/adm5120/patches-2.6.25/007-adm5120_pci.patch
new file mode 100644
index 0000000000..2da99bacb9
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.25/007-adm5120_pci.patch
@@ -0,0 +1,23 @@
+Index: linux-2.6.25/arch/mips/pci/Makefile
+===================================================================
+--- linux-2.6.25.orig/arch/mips/pci/Makefile
++++ linux-2.6.25/arch/mips/pci/Makefile
+@@ -48,3 +48,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
+ obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
+ obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
+ obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
++obj-$(CONFIG_PCI_ADM5120) += pci-adm5120.o
+Index: linux-2.6.25/include/linux/pci_ids.h
+===================================================================
+--- linux-2.6.25.orig/include/linux/pci_ids.h
++++ linux-2.6.25/include/linux/pci_ids.h
+@@ -1704,6 +1704,9 @@
+ #define PCI_VENDOR_ID_ESDGMBH 0x12fe
+ #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000