aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.25/003-adm5120_switch.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-02 08:52:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-02 08:52:37 +0000
commitaaac1064de71c495d284b981d83f70d3bd445826 (patch)
tree7c16764a4adcbec9b238e77d43c50d7830d5a82e /target/linux/adm5120/patches-2.6.25/003-adm5120_switch.patch
parent9b7ea0451a082c8e9598f639c245f2ab9233a9fb (diff)
downloadupstream-aaac1064de71c495d284b981d83f70d3bd445826.tar.gz
upstream-aaac1064de71c495d284b981d83f70d3bd445826.tar.bz2
upstream-aaac1064de71c495d284b981d83f70d3bd445826.zip
add initial support for 2.6.25
SVN-Revision: 11005
Diffstat (limited to 'target/linux/adm5120/patches-2.6.25/003-adm5120_switch.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.25/003-adm5120_switch.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.25/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.25/003-adm5120_switch.patch
new file mode 100644
index 0000000000..69a0182203
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.25/003-adm5120_switch.patch
@@ -0,0 +1,27 @@
+Index: linux-2.6.25/drivers/net/Kconfig
+===================================================================
+--- linux-2.6.25.orig/drivers/net/Kconfig
++++ linux-2.6.25/drivers/net/Kconfig
+@@ -606,6 +606,10 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config MIPS_ADM5120_ENET
++ tristate "MIPS ADM5120 Ethernet switch support"
++ depends on MIPS_ADM5120
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+Index: linux-2.6.25/drivers/net/Makefile
+===================================================================
+--- linux-2.6.25.orig/drivers/net/Makefile
++++ linux-2.6.25/drivers/net/Makefile
+@@ -187,6 +187,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+ # This is also a 82596 and should probably be merged
+ obj-$(CONFIG_LP486E) += lp486e.o
+
++obj-$(CONFIG_MIPS_ADM5120_ENET) += adm5120sw.o
+ obj-$(CONFIG_ETH16I) += eth16i.o
+ obj-$(CONFIG_ZORRO8390) += zorro8390.o
+ obj-$(CONFIG_HPLANCE) += hplance.o 7990.o