aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.24/002-adm5120_flash.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-01-30 15:25:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-01-30 15:25:48 +0000
commit128bb0967a612a4359d29173f4d11a1716e5bf2a (patch)
treed4aa6c5844db9d0bef508776694aac64ebe22352 /target/linux/adm5120/patches-2.6.24/002-adm5120_flash.patch
parent9bfca5ce18c5d02afc66a1c61fd85288d7af5d9e (diff)
downloadupstream-128bb0967a612a4359d29173f4d11a1716e5bf2a.tar.gz
upstream-128bb0967a612a4359d29173f4d11a1716e5bf2a.tar.bz2
upstream-128bb0967a612a4359d29173f4d11a1716e5bf2a.zip
add preliminary support for 2.6.24
SVN-Revision: 10329
Diffstat (limited to 'target/linux/adm5120/patches-2.6.24/002-adm5120_flash.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.24/002-adm5120_flash.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.24/002-adm5120_flash.patch b/target/linux/adm5120/patches-2.6.24/002-adm5120_flash.patch
new file mode 100644
index 0000000000..a1eea9f0da
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.24/002-adm5120_flash.patch
@@ -0,0 +1,26 @@
+Index: linux-2.6.24/drivers/mtd/maps/Kconfig
+===================================================================
+--- linux-2.6.24.orig/drivers/mtd/maps/Kconfig
++++ linux-2.6.24/drivers/mtd/maps/Kconfig
+@@ -597,5 +597,9 @@ config MTD_PLATRAM
+
+ This selection automatically selects the map_ram driver.
+
++config MTD_ADM5120
++ tristate "Map driver for ADM5120 based boards"
++ depends on MIPS_ADM5120
++
+ endmenu
+
+Index: linux-2.6.24/drivers/mtd/maps/Makefile
+===================================================================
+--- linux-2.6.24.orig/drivers/mtd/maps/Makefile
++++ linux-2.6.24/drivers/mtd/maps/Makefile
+@@ -45,6 +45,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
+ obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
+ obj-$(CONFIG_MTD_PCI) += pci.o
+ obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
++obj-$(CONFIG_MTD_ADM5120) += adm5120-flash.o
+ obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
+ obj-$(CONFIG_MTD_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_IMPA7) += impa7.o