aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.23
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-10-23 10:46:19 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-10-23 10:46:19 +0000
commit2514d7f79927c8e3935c594c9ec4fa007333ade8 (patch)
tree004a11649aa8c4173752faa9820bbc525081d40c /target/linux/adm5120/patches-2.6.23
parent486492b407f7e979b3cac1a23d3ace14f80112f0 (diff)
downloadupstream-2514d7f79927c8e3935c594c9ec4fa007333ade8.tar.gz
upstream-2514d7f79927c8e3935c594c9ec4fa007333ade8.tar.bz2
upstream-2514d7f79927c8e3935c594c9ec4fa007333ade8.zip
The RB513 CF driver is now a module, enable it by default for the RB1xx profile. Fix the membase of the CF driver.
SVN-Revision: 9416
Diffstat (limited to 'target/linux/adm5120/patches-2.6.23')
-rw-r--r--target/linux/adm5120/patches-2.6.23/120-cf.patch14
1 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/adm5120/patches-2.6.23/120-cf.patch b/target/linux/adm5120/patches-2.6.23/120-cf.patch
index cbfe42d6c3..6a41651304 100644
--- a/target/linux/adm5120/patches-2.6.23/120-cf.patch
+++ b/target/linux/adm5120/patches-2.6.23/120-cf.patch
@@ -7,7 +7,7 @@ Index: linux-2.6.23/drivers/block/Kconfig
module will be called z2ram.
+config BLK_DEV_CF_MIPS
-+ bool "CF slot of RB153 board"
++ tristate "CF slot of RB153 board"
+ depends on MIPS_ADM5120
+ default y
+ help
@@ -29,3 +29,15 @@ Index: linux-2.6.23/drivers/block/Makefile
obj-$(CONFIG_AMIGA_FLOPPY) += amiflop.o
obj-$(CONFIG_PS3_DISK) += ps3disk.o
obj-$(CONFIG_ATARI_FLOPPY) += ataflop.o
+diff --git a/fs/partitions/check.c b/fs/partitions/check.c
+index 722e12e..60af038 100644
+--- a/fs/partitions/check.c
++++ b/fs/partitions/check.c
+@@ -526,6 +526,7 @@ exit:
+ kobject_uevent(&p->kobj, KOBJ_ADD);
+ }
+ }
++EXPORT_SYMBOL(register_disk);
+
+ int rescan_partitions(struct gendisk *disk, struct block_device *bdev)
+ {