aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.23/310-adm5120_wdt.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-12-27 14:40:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-12-27 14:40:03 +0000
commitcfcbc078dcb349a0555fce491194c07d2261bd86 (patch)
treed74b004636ad7f4d3684fb449da28771eb457ac0 /target/linux/adm5120/patches-2.6.23/310-adm5120_wdt.patch
parentd0cba247758b13788e605bd7be32e08d345f4c2b (diff)
downloadupstream-cfcbc078dcb349a0555fce491194c07d2261bd86.tar.gz
upstream-cfcbc078dcb349a0555fce491194c07d2261bd86.tar.bz2
upstream-cfcbc078dcb349a0555fce491194c07d2261bd86.zip
add watchdog driver
Here is the driver for the hardware watchdog timer in ADM5120 SoC. Patch is against current svn Kamikaze. Here is only kernel driver. To activate watchdog you have to use some userspace software writing to watchdog device. I think there is one in busybox. Signed-off-by: Ondrej Zajicek <santiago@crfreenet.org> SVN-Revision: 9961
Diffstat (limited to 'target/linux/adm5120/patches-2.6.23/310-adm5120_wdt.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.23/310-adm5120_wdt.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.23/310-adm5120_wdt.patch b/target/linux/adm5120/patches-2.6.23/310-adm5120_wdt.patch
new file mode 100644
index 0000000000..55f7b93b46
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.23/310-adm5120_wdt.patch
@@ -0,0 +1,33 @@
+diff -urN linux-2.6.23.11-old/drivers/char/watchdog/Kconfig linux-2.6.23.11/drivers/char/watchdog/Kconfig
+--- linux-2.6.23.11-old/drivers/char/watchdog/Kconfig 2007-12-15 04:50:05.000000000 +0100
++++ linux-2.6.23.11/drivers/char/watchdog/Kconfig 2007-12-26 20:17:56.000000000 +0100
+@@ -583,6 +583,18 @@
+
+ # MIPS Architecture
+
++config ADM5120_WDT
++ tristate "Infineon ADM5120 SoC hardware watchdog"
++ depends on WATCHDOG && MIPS_ADM5120
++ help
++ This is a driver for hardware watchdog integrated in Infineon
++ ADM5120 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called adm5120_wdt.
++
+ config INDYDOG
+ tristate "Indy/I2 Hardware Watchdog"
+ depends on SGI_IP22
+diff -urN linux-2.6.23.11-old/drivers/char/watchdog/Makefile linux-2.6.23.11/drivers/char/watchdog/Makefile
+--- linux-2.6.23.11-old/drivers/char/watchdog/Makefile 2007-12-15 04:50:05.000000000 +0100
++++ linux-2.6.23.11/drivers/char/watchdog/Makefile 2007-12-26 20:19:24.000000000 +0100
+@@ -87,6 +87,7 @@
+ # M68KNOMMU Architecture
+
+ # MIPS Architecture
++obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
+ obj-$(CONFIG_INDYDOG) += indydog.o
+ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
+ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o