aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.23/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-11 07:45:02 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-11 07:45:02 +0000
commit1f802675efe51029912d6c2391b054011e93abe0 (patch)
tree0aeb211ac98d1d7cb63286f7acf13a1bd1a6e6b1 /target/linux/adm5120/patches-2.6.23/103-mtd_trxsplit.patch
parent36c579aee3a396ab21336ebaa09c4a666267973c (diff)
downloadupstream-1f802675efe51029912d6c2391b054011e93abe0.tar.gz
upstream-1f802675efe51029912d6c2391b054011e93abe0.tar.bz2
upstream-1f802675efe51029912d6c2391b054011e93abe0.zip
prepare for 2.6.23
SVN-Revision: 9258
Diffstat (limited to 'target/linux/adm5120/patches-2.6.23/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.23/103-mtd_trxsplit.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.23/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.23/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..76f22d4439
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.23/103-mtd_trxsplit.patch
@@ -0,0 +1,28 @@
+Index: linux-2.6.23/drivers/mtd/Kconfig
+===================================================================
+--- linux-2.6.23.orig/drivers/mtd/Kconfig
++++ linux-2.6.23/drivers/mtd/Kconfig
+@@ -57,6 +57,11 @@ config MTD_ROOTFS_SPLIT
+ depends on MTD_PARTITIONS
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ depends on MTD_PARTITIONS
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ depends on MTD_PARTITIONS
+Index: linux-2.6.23/drivers/mtd/Makefile
+===================================================================
+--- linux-2.6.23.orig/drivers/mtd/Makefile
++++ linux-2.6.23/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
+ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
+
+ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o