aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.22
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-01 09:51:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-01 09:51:32 +0000
commitffec4f291341a1e158b8c13d51219fa7ecfae244 (patch)
treee9b3ff24cbab3de0861886ef146a54661bc97a10 /target/linux/adm5120/patches-2.6.22
parent693077d7d5df84f5cf72239effbb514a478daf96 (diff)
downloadupstream-ffec4f291341a1e158b8c13d51219fa7ecfae244.tar.gz
upstream-ffec4f291341a1e158b8c13d51219fa7ecfae244.tar.bz2
upstream-ffec4f291341a1e158b8c13d51219fa7ecfae244.zip
prepare trxsplit to support sysupgrade
SVN-Revision: 9085
Diffstat (limited to 'target/linux/adm5120/patches-2.6.22')
-rw-r--r--target/linux/adm5120/patches-2.6.22/103-mtd_trxsplit.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.22/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.22/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..c623bc42e4
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.22/103-mtd_trxsplit.patch
@@ -0,0 +1,28 @@
+Index: linux-2.6.22.4/drivers/mtd/Kconfig
+===================================================================
+--- linux-2.6.22.4.orig/drivers/mtd/Kconfig
++++ linux-2.6.22.4/drivers/mtd/Kconfig
+@@ -57,6 +57,11 @@ config MTD_ROOTFS_SPLIT
+ depends on MTD_PARTITIONS
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ depends on MTD_PARTITIONS
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ depends on MTD_PARTITIONS
+Index: linux-2.6.22.4/drivers/mtd/Makefile
+===================================================================
+--- linux-2.6.22.4.orig/drivers/mtd/Makefile
++++ linux-2.6.22.4/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.
+ obj-$(CONFIG_MTD) += $(mtd-y)
+
+ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o