aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.22
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-09-28 06:32:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-09-28 06:32:40 +0000
commitc0b6f797308133919ab16e51ec9832e81720f9bc (patch)
treef68e7cbdab84daced5fc355ea7a40bb7b94a7c7a /target/linux/adm5120/patches-2.6.22
parent969ac7459ee6f948ea1c8804cc38d659e0c4a9d1 (diff)
downloadupstream-c0b6f797308133919ab16e51ec9832e81720f9bc.tar.gz
upstream-c0b6f797308133919ab16e51ec9832e81720f9bc.tar.bz2
upstream-c0b6f797308133919ab16e51ec9832e81720f9bc.zip
add morse LED trigger, will be used for diagnostic, update kernel config
SVN-Revision: 9053
Diffstat (limited to 'target/linux/adm5120/patches-2.6.22')
-rw-r--r--target/linux/adm5120/patches-2.6.22/300-ledtrig_morse.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.22/300-ledtrig_morse.patch b/target/linux/adm5120/patches-2.6.22/300-ledtrig_morse.patch
new file mode 100644
index 0000000000..f1602ed1cc
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.22/300-ledtrig_morse.patch
@@ -0,0 +1,19 @@
+--- linux-2.6.21.1.orig/drivers/leds/Kconfig 2007-09-09 07:15:28.000000000 +0200
++++ linux-2.6.21.1/drivers/leds/Kconfig 2007-09-13 19:36:35.000000000 +0200
+@@ -149,5 +149,9 @@
+ load average.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endmenu
+
+--- linux-2.6.21.1.orig/drivers/leds/Makefile 2007-09-09 07:15:28.000000000 +0200
++++ linux-2.6.21.1/drivers/leds/Makefile 2007-09-13 19:33:15.000000000 +0200
+@@ -23,3 +23,4 @@
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
+ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o