aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.22/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit56231056ea784f1cec6450f649b1adaed1f56366 (patch)
tree7b130d72d854cde2bcd3af8b11bd0f7be3dbff6a /target/linux/adm5120/patches-2.6.22/007-adm5120_pci.patch
parente1184aaa1a7a5e5eeef8e072bf0ea98c291be22a (diff)
downloadupstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.gz
upstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.bz2
upstream-56231056ea784f1cec6450f649b1adaed1f56366.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
SVN-Revision: 8653
Diffstat (limited to 'target/linux/adm5120/patches-2.6.22/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.22/007-adm5120_pci.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.22/007-adm5120_pci.patch b/target/linux/adm5120/patches-2.6.22/007-adm5120_pci.patch
new file mode 100644
index 0000000000..71b97ed126
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.22/007-adm5120_pci.patch
@@ -0,0 +1,23 @@
+Index: linux-2.6.22.1/arch/mips/pci/Makefile
+===================================================================
+--- linux-2.6.22.1.orig/arch/mips/pci/Makefile
++++ linux-2.6.22.1/arch/mips/pci/Makefile
+@@ -50,3 +50,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
+ obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
+ obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
+ obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
++obj-$(CONFIG_PCI_ADM5120) += fixup-adm5120.o ops-adm5120.o pci-adm5120.o
+Index: linux-2.6.22.1/include/linux/pci_ids.h
+===================================================================
+--- linux-2.6.22.1.orig/include/linux/pci_ids.h
++++ linux-2.6.22.1/include/linux/pci_ids.h
+@@ -1713,6 +1713,9 @@
+ #define PCI_VENDOR_ID_ESDGMBH 0x12fe
+ #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000