aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit56231056ea784f1cec6450f649b1adaed1f56366 (patch)
tree7b130d72d854cde2bcd3af8b11bd0f7be3dbff6a /target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch
parente1184aaa1a7a5e5eeef8e072bf0ea98c291be22a (diff)
downloadupstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.gz
upstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.bz2
upstream-56231056ea784f1cec6450f649b1adaed1f56366.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
SVN-Revision: 8653
Diffstat (limited to 'target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch b/target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch
new file mode 100644
index 0000000000..79915e0281
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.22.1/drivers/mtd/nand/Kconfig
+===================================================================
+--- linux-2.6.22.1.orig/drivers/mtd/nand/Kconfig
++++ linux-2.6.22.1/drivers/mtd/nand/Kconfig
+@@ -81,6 +81,12 @@ config MTD_NAND_TS7250
+ help
+ Support for NAND flash on Technologic Systems TS-7250 platform.
+
++config MTD_NAND_RB100
++ tristate "NAND Flash device on RB100 board"
++ depends on MTD_NAND
++ help
++ Support for NAND flash on RB100 platform.
++
+ config MTD_NAND_IDS
+ tristate
+
+Index: linux-2.6.22.1/drivers/mtd/nand/Makefile
+===================================================================
+--- linux-2.6.22.1.orig/drivers/mtd/nand/Makefile
++++ linux-2.6.22.1/drivers/mtd/nand/Makefile
+@@ -10,6 +10,7 @@ obj-$(CONFIG_MTD_NAND_CAFE) += cafe_nan
+ obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
+ obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-delta.o
+ obj-$(CONFIG_MTD_NAND_TOTO) += toto.o
++obj-$(CONFIG_MTD_NAND_RB100) += rbmipsnand.o
+ obj-$(CONFIG_MTD_NAND_AUTCPU12) += autcpu12.o
+ obj-$(CONFIG_MTD_NAND_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o