aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/patches
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-17 22:15:50 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-17 22:15:50 +0000
commitd22c77b8089747f892ce5b9baee55b3cb438ba26 (patch)
tree90793f436617923425eeb27c976e05d30bfe6e58 /target/linux/adm5120-2.6/patches
parent29300267d3240a41a265b9e4b7415431d1aabdb1 (diff)
downloadupstream-d22c77b8089747f892ce5b9baee55b3cb438ba26.tar.gz
upstream-d22c77b8089747f892ce5b9baee55b3cb438ba26.tar.bz2
upstream-d22c77b8089747f892ce5b9baee55b3cb438ba26.zip
Move NAND driver from rb1xx to adm5120, rbmipsnand fixed by David Goodenough, thanks !
SVN-Revision: 6991
Diffstat (limited to 'target/linux/adm5120-2.6/patches')
-rw-r--r--target/linux/adm5120-2.6/patches/500-Nand.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/adm5120-2.6/patches/500-Nand.patch b/target/linux/adm5120-2.6/patches/500-Nand.patch
new file mode 100644
index 0000000000..05beb20241
--- /dev/null
+++ b/target/linux/adm5120-2.6/patches/500-Nand.patch
@@ -0,0 +1,29 @@
+diff --git a/drivers/mtd/nand/Kconfig b/drivers/mtd/nand/Kconfig
+index cfe288a..c528024 100644
+--- a/drivers/mtd/nand/Kconfig
++++ b/drivers/mtd/nand/Kconfig
+@@ -55,6 +55,12 @@ config MTD_NAND_TOTO
+ help
+ Support for NAND flash on Texas Instruments Toto platform.
+
++config MTD_NAND_RB100
++ tristate "NAND Flash device on RB100 board"
++ depends on MTD_NAND
++ help
++ Support for NAND flash on RB100 platform.
++
+ config MTD_NAND_IDS
+ tristate
+
+diff --git a/drivers/mtd/nand/Makefile b/drivers/mtd/nand/Makefile
+index 4174202..2be57c1 100644
+--- a/drivers/mtd/nand/Makefile
++++ b/drivers/mtd/nand/Makefile
+@@ -8,6 +8,7 @@ obj-$(CONFIG_MTD_NAND_IDS) += nand_ids.
+
+ obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
+ obj-$(CONFIG_MTD_NAND_TOTO) += toto.o
++obj-$(CONFIG_MTD_NAND_RB100) += rbmipsnand.o
+ obj-$(CONFIG_MTD_NAND_AUTCPU12) += autcpu12.o
+ obj-$(CONFIG_MTD_NAND_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o