aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-05-11 22:20:39 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-05-11 22:20:39 +0000
commit128103ed7df35177eb9fb07c960a14526135906b (patch)
treecb6b16a6409041c9649fae398ab8f65fa2e0873d /target/linux/adm5120-2.6/image
parent2973918adafe84bba8239debb64b6f7aa0005a0d (diff)
downloadupstream-128103ed7df35177eb9fb07c960a14526135906b.tar.gz
upstream-128103ed7df35177eb9fb07c960a14526135906b.tar.bz2
upstream-128103ed7df35177eb9fb07c960a14526135906b.zip
Add a RB1xx profile to generate RouterBoard RB1xx series image and kernel command line hack patch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7194 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120-2.6/image')
-rw-r--r--target/linux/adm5120-2.6/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/adm5120-2.6/image/Makefile b/target/linux/adm5120-2.6/image/Makefile
index 025146077f..9c7b9bd7be 100644
--- a/target/linux/adm5120-2.6/image/Makefile
+++ b/target/linux/adm5120-2.6/image/Makefile
@@ -62,6 +62,10 @@ define Image/Build/MyLoader
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).bin
endef
+define Image/Build/RouterBoard
+ $(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
+endef
+
define Image/Build
$(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
$(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-noloader.trx -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
@@ -88,6 +92,9 @@ ifneq ($(1),jffs2-128K)
$(call Image/Build/MyLoader,$(1),wpp54g,$(patsubst jffs2-%,jffs2,$(1)),WPP54G)
$(call Image/Build/MyLoader,$(1),wpp54ag,$(patsubst jffs2-%,jffs2,$(1)),WPP54AG)
endif
+ifeq ($(1),tgz)
+ $(call Image/Build/RouterBoard)
+endif
endef
$(eval $(call BuildImage))