aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/image/lzma-loader/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-02 17:14:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-02 17:14:23 +0000
commit75af0330e09a995a10a02cc4d7eeae11174084eb (patch)
treed662ddda7b2332094c0a634d959bd552cd0acb3b /target/linux/adm5120-2.6/image/lzma-loader/Makefile
parent5218d952cd4fd2137cc5668ff5205db25012d42c (diff)
downloadupstream-75af0330e09a995a10a02cc4d7eeae11174084eb.tar.gz
upstream-75af0330e09a995a10a02cc4d7eeae11174084eb.tar.bz2
upstream-75af0330e09a995a10a02cc4d7eeae11174084eb.zip
Entry point is now configurable via a Makefile variable. Entry point is detected automatically (Gabor Juhos)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6841 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120-2.6/image/lzma-loader/Makefile')
-rw-r--r--target/linux/adm5120-2.6/image/lzma-loader/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/target/linux/adm5120-2.6/image/lzma-loader/Makefile b/target/linux/adm5120-2.6/image/lzma-loader/Makefile
index e2afb186e0..8ce2688234 100644
--- a/target/linux/adm5120-2.6/image/lzma-loader/Makefile
+++ b/target/linux/adm5120-2.6/image/lzma-loader/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -8,6 +8,9 @@
include $(TOPDIR)/rules.mk
+LOADER := loader
+BZ_STARTUP_ORG := 0
+
PKG_NAME := lzma-loader
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
@@ -16,18 +19,19 @@ $(PKG_BUILD_DIR)/.prepared:
$(CP) ./src/* $(PKG_BUILD_DIR)/
touch $@
-$(PKG_BUILD_DIR)/loader.gz: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/$(LOADER).gz: $(PKG_BUILD_DIR)/.prepared
$(MAKE) -C $(PKG_BUILD_DIR) CC="$(TARGET_CC)" \
- LD="$(TARGET_CROSS)ld" CROSS_COMPILE="$(TARGET_CROSS)"
+ LD="$(TARGET_CROSS)ld" CROSS_COMPILE="$(TARGET_CROSS)" \
+ LOADER=$(LOADER) BZ_STARTUP_ORG=$(BZ_STARTUP_ORG)
-download:
+download:
prepare: $(PKG_BUILD_DIR)/.prepared
-compile: $(PKG_BUILD_DIR)/loader.gz
+compile: $(PKG_BUILD_DIR)/$(LOADER).gz
install:
ifneq ($(TARGET),)
install: compile
- $(CP) $(PKG_BUILD_DIR)/loader.gz $(PKG_BUILD_DIR)/loader.elf $(TARGET)/
+ $(CP) $(PKG_BUILD_DIR)/$(LOADER).gz $(PKG_BUILD_DIR)/$(LOADER).elf $(TARGET)/
endif
clean: