aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/files/drivers/serial
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-07-13 13:14:08 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-07-13 13:14:08 +0000
commite2b75c370e0e0fa5e8a558d9bd5b034fa9ebe829 (patch)
tree41665f18fb89561ae5ef8cd4a5d15e4b1e89af48 /target/linux/adm5120-2.6/files/drivers/serial
parentd700970b00e10c9d23504130168e505595cc7cc8 (diff)
downloadupstream-e2b75c370e0e0fa5e8a558d9bd5b034fa9ebe829.tar.gz
upstream-e2b75c370e0e0fa5e8a558d9bd5b034fa9ebe829.tar.bz2
upstream-e2b75c370e0e0fa5e8a558d9bd5b034fa9ebe829.zip
Fix the section mismatch on the serial driver (#2076), thanks Thomas !
SVN-Revision: 7967
Diffstat (limited to 'target/linux/adm5120-2.6/files/drivers/serial')
-rw-r--r--target/linux/adm5120-2.6/files/drivers/serial/adm5120_uart.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/adm5120-2.6/files/drivers/serial/adm5120_uart.c b/target/linux/adm5120-2.6/files/drivers/serial/adm5120_uart.c
index 8a2adaa9c4..83c5f72012 100644
--- a/target/linux/adm5120-2.6/files/drivers/serial/adm5120_uart.c
+++ b/target/linux/adm5120-2.6/files/drivers/serial/adm5120_uart.c
@@ -433,7 +433,7 @@ static void adm5120console_write(struct console *con, const char *s,
}
}
-static int __init adm5120console_setup(struct console *con, char *options)
+static int adm5120console_setup(struct console *con, char *options)
{
/* Set to 115200 baud, 8N1 and enable FIFO */
ADM5120_UART_REG(ADM5120_UART0_BASE, ADM5120_UART_LCR_L) =
ight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
# 
# Copyright (C) 2007-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# Main makefile for the toolchain
#
# Steps:
# 1) toolchain/binutils/install
#    build & install binutils
# 2) toolchain/gcc/minimal/install
#    build & install a minimal gcc, needed for steps 3 & 4
# 3) toolchain/kernel-headers/install
#    install kernel headers, needed for step 4
# 4) toolchain/libc/headers/install
#    build & install libc headers & support files, needed for step 5
# 5) toolchain/gcc/initial/install
#    build & install an initial gcc, needed for step 6
# 6) toolchain/libc/install
#    build & install the final libc
# 7) toolchain/gcc/final/install
#    build & install the final gcc
# 8) toolchain/libc/utils/install
#    build & install libc utilities
#
# For musl, steps 2 and 4 are skipped, and step 3 is done after 5

curdir:=toolchain

# subdirectories to descend into
$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers)
ifdef CONFIG_USE_UCLIBC
  $(curdir)/builddirs += $(LIBC)/utils
endif

# builddir dependencies
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
  ifdef CONFIG_USE_MUSL
    $(curdir)/kernel-headers/compile:=$(curdir)/gcc/initial/install
    $(curdir)/$(LIBC)/compile:=$(curdir)/kernel-headers/install
  else
    $(curdir)/builddirs += $(LIBC)/headers gcc/minimal
    $(curdir)/gcc/minimal/compile:=$(curdir)/binutils/install
    $(curdir)/kernel-headers/compile:=$(curdir)/gcc/minimal/install
    $(curdir)/gcc/initial/prepare:=$(curdir)/gcc/minimal/prepare
    $(curdir)/$(LIBC)/prepare:=$(curdir)/$(LIBC)/headers/prepare
    $(curdir)/$(LIBC)/headers/compile:=$(curdir)/kernel-headers/install
    $(curdir)/gcc/initial/compile:=$(curdir)/$(LIBC)/headers/install
  endif

  $(curdir)/gcc/initial/compile+=$(curdir)/binutils/install
  $(curdir)/gcc/final/prepare:=$(curdir)/gcc/initial/prepare
  $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/install
  $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/install
  $(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/install
  $(curdir)/$(LIBC)/utils/prepare:=$(curdir)/$(LIBC)/headers/prepare
endif

$(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)

ifndef DUMP_TARGET_DB
ifneq ($(ARCH),)
  $(TOOLCHAIN_DIR)/info.mk: .config
	@for dir in $(TOOLCHAIN_DIR); do ( \
		$(if $(QUIET),,set -x;) \
		mkdir -p "$$dir"; \
		cd "$$dir"; \
		ln -nsf lib lib64; \
		ln -nsf lib lib32; \
		mkdir -p stamp lib usr/include usr/lib ; \
	); done
	@grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
	@touch $@
endif
endif

# prerequisites for the individual targets
$(curdir)/ := .config prereq
$(curdir)//prepare = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk $(tools/stamp-install)
$(curdir)//compile = $(1)/prepare
$(curdir)//install = $(1)/compile

ifndef DUMP_TARGET_DB
$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
endif

$(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
$(eval $(call subdir,$(curdir)))