aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:45 +0000
commitf4e7bdac427e5cf7c06378fdb68e6f1780bcaff4 (patch)
treebeda70cdc408c3248d07dec3bf53f7170d5623c2 /target/linux/Makefile
parentef36c74b06f8fdc5d4e81b1bdfc1e3ad275e560f (diff)
downloadupstream-f4e7bdac427e5cf7c06378fdb68e6f1780bcaff4.tar.gz
upstream-f4e7bdac427e5cf7c06378fdb68e6f1780bcaff4.tar.bz2
upstream-f4e7bdac427e5cf7c06378fdb68e6f1780bcaff4.zip
large improvement for parallel builds. works without V=99 now and without warnings. tested with -j on an 2x dual core opteron machine
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11414 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/Makefile')
-rw-r--r--target/linux/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/Makefile b/target/linux/Makefile
index 8288250111..1bdd5ae149 100644
--- a/target/linux/Makefile
+++ b/target/linux/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
-prereq clean download prepare compile install menuconfig oldconfig update refresh: FORCE
- TARGET_BUILD=1 $(MAKE) -C $(BOARD) $@
+export TARGET_BUILD=1
+prereq clean download prepare compile install menuconfig oldconfig update refresh: FORCE
+ @$(NO_TRACE_MAKE) -C $(BOARD) $@