aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-01-31 21:55:38 +0000
committerMike Baker <mbm@openwrt.org>2006-01-31 21:55:38 +0000
commit4051a0a87c963cf52c0ad1e5974739c5ec5d5fbd (patch)
treeb29a26c699c64311c74709b8aee1d954f4c0f6d0 /target/linux/Makefile
parent2c4b4d39a77494dd432b192ba58ce1f7158e7fcb (diff)
downloadupstream-4051a0a87c963cf52c0ad1e5974739c5ec5d5fbd.tar.gz
upstream-4051a0a87c963cf52c0ad1e5974739c5ec5d5fbd.tar.bz2
upstream-4051a0a87c963cf52c0ad1e5974739c5ec5d5fbd.zip
fix "make target/linux/package/*-*" targets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3103 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/Makefile')
-rw-r--r--target/linux/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/Makefile b/target/linux/Makefile
index 2fff3b33af..626587b5b0 100644
--- a/target/linux/Makefile
+++ b/target/linux/Makefile
@@ -45,6 +45,8 @@ compile: $(1)/$(2)-compile
rebuild: $(1)/$(2)-rebuild
$(BIN_DIR)/$(IB_NAME).tar.bz2 install: $(1)/$(2)-image
install-ib: $(1)/$(2)-install-ib
+package/%:
+ $(MAKE) -C $(2)-$(1) BOARD="$(2)" $$@
endif
.PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-rebuild $(1)/$(2)-install $(1)/$(2)-image $(1)/$(2)-install-ib