aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-03-24 06:52:37 +0100
committerPetr Štetiar <ynezz@true.cz>2022-03-25 14:54:41 +0100
commitec9af870f3278f75549836b469baefa260e2ed41 (patch)
tree94c70bd4207d17cd088097cdb76c7400a6da7277 /target/imagebuilder
parent161ff660fc72e32984885f1866e842109262630d (diff)
downloadupstream-ec9af870f3278f75549836b469baefa260e2ed41.tar.gz
upstream-ec9af870f3278f75549836b469baefa260e2ed41.tar.bz2
upstream-ec9af870f3278f75549836b469baefa260e2ed41.zip
imagebuilder: fix broken image generation with external targets
When using external targets there is a symlink being created for the target under target/linux which then becomes dangling under Image Builder. Fix it by dereferencing the possible symlink. Tested on IB with external target, ipq40xx and mvebu. Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 621f39d1f438bf95dbae667c575926fa16a6d797)
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 8607a2d709..3bbadc7204 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -78,7 +78,7 @@ ifneq ($(CONFIG_SIGNATURE_CHECK),)
$(CP) -L $(STAGING_DIR_ROOT)/usr/sbin/opkg-key $(PKG_BUILD_DIR)/scripts/
endif
- $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
+ $(CP) -L $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
if [ -d $(TOPDIR)/staging_dir/host/lib/grub ]; then \
$(CP) $(TOPDIR)/staging_dir/host/lib/grub/ $(PKG_BUILD_DIR)/staging_dir/host/lib; \
fi