aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-15 13:28:26 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-15 13:28:26 +0000
commita719519ec6ba3062311d6ba5ee7d4486df0524e8 (patch)
tree8ed3c1024754e04aa7a447ee01cda96aee16679b /target/imagebuilder
parent81fa3831f89f29b74510c5ac77db6a1cec985704 (diff)
downloadupstream-a719519ec6ba3062311d6ba5ee7d4486df0524e8.tar.gz
upstream-a719519ec6ba3062311d6ba5ee7d4486df0524e8.tar.bz2
upstream-a719519ec6ba3062311d6ba5ee7d4486df0524e8.zip
[iamgebuilder] use bundle-libraries.sh to install required host utilities into imagebuilder staging tree
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33196 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 788e2c2496..5d7b7ab5ed 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -37,7 +37,6 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
$(PKG_BUILD_DIR)/
$(VERSION_SED) $(PKG_BUILD_DIR)/repositories.conf
$(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
- $(CP) $(STAGING_DIR_HOST)/bin $(PKG_BUILD_DIR)/staging_dir/host/
$(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
rm -rf \
$(PKG_BUILD_DIR)/target/linux/*/files{,-*} \
@@ -47,6 +46,8 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
$(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(PKG_BUILD_DIR)/include/version.mk
find $(PKG_BUILD_DIR) -name CVS -o -name .git -o -name .svn \
| $(XARGS) rm -rf
+ find $(STAGING_DIR_HOST)/bin -maxdepth 1 -type f -perm -u=x \
+ | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin
$(TAR) c -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
download: