aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-04-21 11:20:25 +0000
committerNicolas Thill <nico@openwrt.org>2009-04-21 11:20:25 +0000
commit742ee4ef0c4dc5f8a0777926237170add2d1d07f (patch)
tree5f9243291d67222329c52b1805bbd82336c3f651 /target/imagebuilder
parente6654449d48f2338911572f29ae7dae2e75816c7 (diff)
downloadupstream-742ee4ef0c4dc5f8a0777926237170add2d1d07f.tar.gz
upstream-742ee4ef0c4dc5f8a0777926237170add2d1d07f.tar.bz2
upstream-742ee4ef0c4dc5f8a0777926237170add2d1d07f.zip
[imagebuilder] fix initscripts activation (closes: #4037, #4745)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15320 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index e8bd28f318..b526925177 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -131,10 +131,10 @@ package_postinst: FORCE
@echo
@echo Activating init scripts
@( \
- cd $(BUILD_DIR)/root; \
+ cd $(TARGET_DIR); \
for script in ./etc/init.d/*; do \
grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
- IPKG_INSTROOT=$(BUILD_DIR)/root $(which bash) ./etc/rc.common $$script enable; \
+ IPKG_INSTROOT=$(TARGET_DIR) $(which bash) ./etc/rc.common $$script enable; \
done || true; \
)