aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/files
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-14 10:49:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-14 10:49:00 +0000
commit374f384350104a33cf80b19ad2ff58bf0719d5ac (patch)
tree52200259bfd9fa244d06ec2230438be75e4626d5 /target/imagebuilder/files
parent56cb557d107f6df1ae94c7ed38c630eea8fe7776 (diff)
downloadupstream-374f384350104a33cf80b19ad2ff58bf0719d5ac.tar.gz
upstream-374f384350104a33cf80b19ad2ff58bf0719d5ac.tar.bz2
upstream-374f384350104a33cf80b19ad2ff58bf0719d5ac.zip
include .targetinfo in the image builder, and allow direct calls to the package_index target
SVN-Revision: 6093
Diffstat (limited to 'target/imagebuilder/files')
-rw-r--r--target/imagebuilder/files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 720bcfa768..d4bcdf5fa9 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -88,7 +88,7 @@ $(TOPDIR)/tmp/ipkg.conf: FORCE
BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(PACKAGES) $($(PROFILE)_PACKAGES) kernel)
BUILD_PACKAGES:=$(patsubst base-files,base-files-$(BOARD)-$(KERNEL),$(BUILD_PACKAGES))
-image: $(TOPDIR)/tmp/ipkg.conf
+image:
if [ -z "$($(PROFILE)_NAME)" ]; then \
echo Profile $(PROFILE) not found.; \
echo 'Use "make info" to get a list of available target profiles'; \
@@ -107,7 +107,7 @@ endif
$(MAKE) package_postinst
$(MAKE) build_image
-package_index: FORCE
+package_index: $(TOPDIR)/tmp/ipkg.conf FORCE
@echo
@echo Building package index...
(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages) >/dev/null 2>/dev/null