aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-20 12:35:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-20 12:35:00 +0000
commit2fb06d46d9c5a8fc6158bf88f985743e60be3afb (patch)
treea219b0c6e587ba0b08a50cf43188eb3df401f888 /target/imagebuilder/files/Makefile
parent297f2368ba6d2aa7da2fcff19eae0e211720878e (diff)
downloadupstream-2fb06d46d9c5a8fc6158bf88f985743e60be3afb.tar.gz
upstream-2fb06d46d9c5a8fc6158bf88f985743e60be3afb.tar.bz2
upstream-2fb06d46d9c5a8fc6158bf88f985743e60be3afb.zip
Add WL-700gE support (based on work by jr) Includes kernel/diag patch and a new target profile
SVN-Revision: 6142
Diffstat (limited to 'target/imagebuilder/files/Makefile')
-rw-r--r--target/imagebuilder/files/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index fbcfa0d49a..7b35e545dd 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -87,6 +87,8 @@ $(TOPDIR)/tmp/ipkg.conf: FORCE
BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(PACKAGES) $($(PROFILE)_PACKAGES) kernel)
BUILD_PACKAGES:=$(patsubst base-files,base-files-$(BOARD)-$(KERNEL),$(BUILD_PACKAGES))
+# "-pkgname" in the package list means remove "pkgname" from the package list
+BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES)
image:
if [ -z "$($(PROFILE)_NAME)" ]; then \