aboutsummaryrefslogtreecommitdiffstats
path: root/target/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-10-15 23:34:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-10-15 23:34:22 +0000
commit44419aed87f1c2ea1024535edabc1c3a250b6fc8 (patch)
tree777ec7969e32815eb729a942b76a86ba88a36db2 /target/image
parent875927a153f1ea538280afc0ce04e75c91683f5e (diff)
downloadupstream-44419aed87f1c2ea1024535edabc1c3a250b6fc8.tar.gz
upstream-44419aed87f1c2ea1024535edabc1c3a250b6fc8.tar.bz2
upstream-44419aed87f1c2ea1024535edabc1c3a250b6fc8.zip
Merge preliminary rdc-2.6 support (Airlink101 AR525W)
SVN-Revision: 5138
Diffstat (limited to 'target/image')
-rw-r--r--target/image/rdc/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/image/rdc/Makefile b/target/image/rdc/Makefile
new file mode 100644
index 0000000000..06082404ee
--- /dev/null
+++ b/target/image/rdc/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Clean
+endef
+
+define Image/Prepare
+endef
+
+define Image/Prepare
+ cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+endef
+
+define Image/Build/ar525w
+endef
+
+$(call Image/Build/ar525w,$(1),$(patsubst jffs2-%,jffs2,$(1)))
+
+$(eval $(call BuildImage))