aboutsummaryrefslogtreecommitdiffstats
path: root/target/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-31 22:49:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-31 22:49:02 +0000
commit88dd056006c8a6f5cc07f9b0440b4bf490b349d7 (patch)
treec98220b8badab2c5c68c0fb5d68db08ff54b1358 /target/image
parent45f0f2a960993a784a558c0e644880dbb9b4be99 (diff)
downloadupstream-88dd056006c8a6f5cc07f9b0440b4bf490b349d7.tar.gz
upstream-88dd056006c8a6f5cc07f9b0440b4bf490b349d7.tar.bz2
upstream-88dd056006c8a6f5cc07f9b0440b4bf490b349d7.zip
fix rootfs partition name for x86 images
SVN-Revision: 5367
Diffstat (limited to 'target/image')
-rw-r--r--target/image/x86/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/target/image/x86/Makefile b/target/image/x86/Makefile
index fd424ffd00..9b983ad603 100644
--- a/target/image/x86/Makefile
+++ b/target/image/x86/Makefile
@@ -7,6 +7,10 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
+")) # fix vim's broken syntax highlighting
+
+
ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
define Build/Compile
$(MAKE) -C grub compile
@@ -17,15 +21,15 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(CONFIG_X86_GRUB_ROOTPART),65536 root=/dev/mtdblock0 rootfstype=jffs2
+ block2mtd.block2mtd=$(ROOTPART),65536 root=/dev/mtdblock0 rootfstype=jffs2
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(CONFIG_X86_GRUB_ROOTPART),131072 root=/dev/mtdblock0 rootfstype=jffs2
+ block2mtd.block2mtd=$(ROOTPART),131072 root=/dev/mtdblock0 rootfstype=jffs2
endef
define Image/cmdline/ext2
- root=$(CONFIG_X86_GRUB_ROOTPART) rootfstype=ext2 $(CONFIG_X86_GRUB_BOOTOPTS)
+ root=$(ROOTPART) rootfstype=ext2 $(CONFIG_X86_GRUB_BOOTOPTS)
endef
define Image/Build/grub