aboutsummaryrefslogtreecommitdiffstats
path: root/target/image/ixp4xx
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-10-27 10:26:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-10-27 10:26:00 +0000
commit2d2179f503930a0f04673205a97161f015cf42c9 (patch)
treeaec3aa108729cf194c136832fe37ae219dcff795 /target/image/ixp4xx
parent5d434d99598e0f50e031102dc7618849f2f4bc19 (diff)
downloadupstream-2d2179f503930a0f04673205a97161f015cf42c9.tar.gz
upstream-2d2179f503930a0f04673205a97161f015cf42c9.tar.bz2
upstream-2d2179f503930a0f04673205a97161f015cf42c9.zip
rename the xscale target to ixp4xx for the forthcoming iop target, add gcc 4.1 patch for arm
SVN-Revision: 5310
Diffstat (limited to 'target/image/ixp4xx')
-rw-r--r--target/image/ixp4xx/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/image/ixp4xx/Makefile b/target/image/ixp4xx/Makefile
new file mode 100644
index 0000000000..23a0644338
--- /dev/null
+++ b/target/image/ixp4xx/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Clean
+endef
+
+define Image/Prepare
+endef
+
+define Image/BuildKernel
+ cp $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-zImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))