aboutsummaryrefslogtreecommitdiffstats
path: root/target/image/ixp4xx/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-10-27 10:26:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-10-27 10:26:00 +0000
commitf8aa6c7c8f3af42341da4747e227e2dbdb1bf6f8 (patch)
tree3452076d913f8bac995f158c9184a79fd5755f5d /target/image/ixp4xx/Makefile
parent50525d647065b48db63eb738aa5eab4379d6fbe2 (diff)
downloadupstream-f8aa6c7c8f3af42341da4747e227e2dbdb1bf6f8.tar.gz
upstream-f8aa6c7c8f3af42341da4747e227e2dbdb1bf6f8.tar.bz2
upstream-f8aa6c7c8f3af42341da4747e227e2dbdb1bf6f8.zip
rename the xscale target to ixp4xx for the forthcoming iop target, add gcc 4.1 patch for arm
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5310 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/image/ixp4xx/Makefile')
-rw-r--r--target/image/ixp4xx/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/image/ixp4xx/Makefile b/target/image/ixp4xx/Makefile
new file mode 100644
index 0000000000..23a0644338
--- /dev/null
+++ b/target/image/ixp4xx/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Clean
+endef
+
+define Image/Prepare
+endef
+
+define Image/BuildKernel
+ cp $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-zImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))