aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-11-22 01:43:43 -0800
committerFelix Fietkau <nbd@nbd.name>2021-11-22 12:00:40 +0100
commit340c2ed2ef6578483f974e274bf6d638f953a246 (patch)
tree8b4cc72d444b7cea21cbded25901535d506ab4a4 /target/Makefile
parent8f458498768ab164d5e42becca52624448dfe2ee (diff)
downloadupstream-340c2ed2ef6578483f974e274bf6d638f953a246.tar.gz
upstream-340c2ed2ef6578483f974e274bf6d638f953a246.tar.bz2
upstream-340c2ed2ef6578483f974e274bf6d638f953a246.zip
tools/llvm-bpf: move tarball packing to target/llvm-bpf
This ensures that the tarball is regenerated after make clean or after switching to a different target Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/target/Makefile b/target/Makefile
index 7ad26c7177..83f9c4b093 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -7,9 +7,14 @@
curdir:=target
$(curdir)/subtargets:=install
-$(curdir)/builddirs:=linux sdk imagebuilder toolchain
+$(curdir)/builddirs:=linux sdk imagebuilder toolchain llvm-bpf
$(curdir)/builddirs-default:=linux
-$(curdir)/builddirs-install:=linux $(if $(CONFIG_SDK),sdk) $(if $(CONFIG_IB),imagebuilder) $(if $(CONFIG_MAKE_TOOLCHAIN),toolchain)
+$(curdir)/builddirs-install:=\
+ linux \
+ $(if $(CONFIG_SDK),sdk) \
+ $(if $(CONFIG_IB),imagebuilder) \
+ $(if $(CONFIG_MAKE_TOOLCHAIN),toolchain) \
+ $(if $(CONFIG_SDK_LLVM_BPF),llvm-bpf)
$(curdir)/sdk/install:=$(curdir)/linux/install
$(curdir)/imagebuilder/install:=$(curdir)/linux/install