aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-07-10 00:00:01 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-07-12 21:26:42 +0200
commit514a4b3e1b4e42fa796d1c908259ee9e215a77da (patch)
treed6d8d2720a5c7eebd2be5d36f8db2b66bf02fe2f /scripts
parent3e89f58a5ead1511f594704951946a79fc0b79d7 (diff)
downloadupstream-514a4b3e1b4e42fa796d1c908259ee9e215a77da.tar.gz
upstream-514a4b3e1b4e42fa796d1c908259ee9e215a77da.tar.bz2
upstream-514a4b3e1b4e42fa796d1c908259ee9e215a77da.zip
include/feeds.mk: rework generation of opkg distfeeds.conf
Allow enabling/commenting/disabling each feed individually by using a tristate config symbol. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> (cherry picked from commit 16035a7dd370671670693af9ae63368ee4dd731f)
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/feeds5
1 files changed, 3 insertions, 2 deletions
diff --git a/scripts/feeds b/scripts/feeds
index b29e1d5c35..304ef6cbaf 100755
--- a/scripts/feeds
+++ b/scripts/feeds
@@ -824,11 +824,12 @@ sub feed_config() {
my $installed = (-f "feeds/$feed->[1].index");
printf "\tconfig FEED_%s\n", $feed->[1];
- printf "\t\tbool \"Enable feed %s\"\n", $feed->[1];
+ printf "\t\ttristate \"Enable feed %s\"\n", $feed->[1];
printf "\t\tdepends on PER_FEED_REPO\n";
printf "\t\tdefault y\n" if $installed;
printf "\t\thelp\n";
- printf "\t\t Enable the \\\"%s\\\" feed at %s.\n", $feed->[1], $feed->[2][0];
+ printf "\t\t Enable the \\\"%s\\\" feed in opkg distfeeds.conf.\n", $feed->[1];
+ printf "\t\t Say M to add the feed commented out.\n";
printf "\n";
}