aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-01-10 11:59:42 +0000
committerNicolas Thill <nico@openwrt.org>2007-01-10 11:59:42 +0000
commit9009554a34dca2322224f07537a051532037228a (patch)
treeab1f1c9f10262b7ef289f7f51d9f7e58bb3a2bb8 /scripts
parent6a166e60110fa99df466e906f3ea8f32e6b667c8 (diff)
downloadupstream-9009554a34dca2322224f07537a051532037228a.tar.gz
upstream-9009554a34dca2322224f07537a051532037228a.tar.bz2
upstream-9009554a34dca2322224f07537a051532037228a.zip
add a hack to allow source package names in Build-Depends: (PKG_BUILDDEP)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6060 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/gen_deps.pl2
1 files changed, 2 insertions, 0 deletions
diff --git a/scripts/gen_deps.pl b/scripts/gen_deps.pl
index af206f0047..0fc80aae85 100755
--- a/scripts/gen_deps.pl
+++ b/scripts/gen_deps.pl
@@ -28,6 +28,8 @@ while ($line = <>) {
$line =~ /^Source-Makefile: \s*(.+\/([^\/]+)\/Makefile)\s*$/ and do {
$makefile = $1;
$src = $2;
+ defined $pkg{$src} or $pkg{$src} = {};
+ $pkg{$src}->{src} = $src;
};
$line =~ /^Package: \s*(.+)\s*$/ and do {
$name = $1;