aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-05-25 02:31:17 -0400
committerPetr Štetiar <ynezz@true.cz>2023-06-12 22:10:20 +0200
commit948dc515dc5afca45a233471535e7c463866c9a9 (patch)
treea3ab265dc98c7cf7970ad3e5a49fc77324f600c7 /rules.mk
parent145d485d51330c40deccce8e249a1da4b1c283ca (diff)
downloadupstream-948dc515dc5afca45a233471535e7c463866c9a9.tar.gz
upstream-948dc515dc5afca45a233471535e7c463866c9a9.tar.bz2
upstream-948dc515dc5afca45a233471535e7c463866c9a9.zip
treewide: add ORIG_PATH variable
Add a variable that stores the original value of $PATH in the host system's shell, before Make alters it. This can be useful for when it is necessary to ignore symlinks and programs made by the build system. Define this new variable before all instances of 'export PATH:=' or similar. Signed-off-by: Michael Pratt <mcpratt@pm.me> (cherry picked from commit d87a8aa148ddf93b199a759deb088fff73787025)
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index dcac49667b..58c53705a2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -227,6 +227,7 @@ else
endif
endif
+export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH))
export PATH:=$(TARGET_PATH)
export STAGING_DIR STAGING_DIR_HOST STAGING_DIR_HOSTPKG
export SH_FUNC:=. $(INCLUDE_DIR)/shell.sh;