aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJosh Roys <roysjosh@gmail.com>2022-07-23 11:23:16 -0400
committerPetr Štetiar <ynezz@true.cz>2022-09-16 18:50:46 +0200
commit340b138932c3720db227821415f494ac81e8b675 (patch)
treeb1d5de1230eb7c272d9243c21a2b9a3ebaad7489 /rules.mk
parentb5e39355e4121bd6288e2fc4a434a785bd6d6285 (diff)
downloadupstream-340b138932c3720db227821415f494ac81e8b675.tar.gz
upstream-340b138932c3720db227821415f494ac81e8b675.tar.bz2
upstream-340b138932c3720db227821415f494ac81e8b675.zip
scripts: always check certificates
Remove flags from wget and curl instructing them to ignore bad server certificates. Although other mechanisms can protect against malicious modifications of downloads, other vectors of attack may be available to an adversary. TLS certificate verification can be disabled by turning oof the "Enable TLS certificate verification during package download" option enabled by default in the "Global build settings" in "make menuconfig" Signed-off-by: Josh Roys <roysjosh@gmail.com> [ add additional info on how to disable this option ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com> (cherry picked from commit 90c6e3aedf167b0ae1baf376e7800a631681e69a)
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 8a4254e638..1d63d61ee1 100644
--- a/rules.mk
+++ b/rules.mk
@@ -265,6 +265,9 @@ ESED:=$(STAGING_DIR_HOST)/bin/sed -E -i -e
MKHASH:=$(STAGING_DIR_HOST)/bin/mkhash
# MKHASH is used in /scripts, so we export it here.
export MKHASH
+# DOWNLOAD_CHECK_CERTIFICATE is used in /scripts, so we export it here.
+DOWNLOAD_CHECK_CERTIFICATE:=$(CONFIG_DOWNLOAD_CHECK_CERTIFICATE)
+export DOWNLOAD_CHECK_CERTIFICATE
CP:=cp -fpR
LN:=ln -sf
XARGS:=xargs -r