diff options
author | Michal Sojka <sojkam1@fel.cvut.cz> | 2017-02-02 12:13:03 +0100 |
---|---|---|
committer | Felix Fietkau <nbd@nbd.name> | 2017-02-09 14:49:34 +0100 |
commit | 202ae4cc6a910dec2441c45dfdf5814ac4d82518 (patch) | |
tree | 5f8d14e7030da75147c080a533582329fb87bfa6 /rules.mk | |
parent | 7096ed58fdc908144d2c52bf416e9b3b0e48795a (diff) | |
download | upstream-202ae4cc6a910dec2441c45dfdf5814ac4d82518.tar.gz upstream-202ae4cc6a910dec2441c45dfdf5814ac4d82518.tar.bz2 upstream-202ae4cc6a910dec2441c45dfdf5814ac4d82518.zip |
build: Pass -iremap gcc option as a single argument
Passing -iremap argument separately causes problems with projects that
use scons and its ParseFlags function. Consider this SConscript
example:
env = Environment()
d = env.ParseFlags("-iremap one:two")
ParseFlags will interpret one:two as a file name and the returned dict
d will contain only "-iremap". When the -iremap is passed to the
compiler without an argument, compilation obviously fails.
Signed-off-by: Michal Sojka <sojkam1@fel.cvut.cz>
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -139,7 +139,7 @@ else endif ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_GCC_VERSION_4_8),$(CONFIG_TARGET_uml)),) - iremap = -iremap $(1):$(2) + iremap = -iremap$(1):$(2) endif PACKAGE_DIR:=$(BIN_DIR)/packages |