diff options
author | Jo-Philipp Wich <jow@openwrt.org> | 2010-09-12 20:49:54 +0000 |
---|---|---|
committer | Jo-Philipp Wich <jow@openwrt.org> | 2010-09-12 20:49:54 +0000 |
commit | 69c9cad2a1144523a6534a184064601e6cc8d48c (patch) | |
tree | a6707cab21cdb4936905ec876e354466e8c90153 /rules.mk | |
parent | 306fd791257af34804c8f7b3322bef61a517d56c (diff) | |
download | upstream-69c9cad2a1144523a6534a184064601e6cc8d48c.tar.gz upstream-69c9cad2a1144523a6534a184064601e6cc8d48c.tar.bz2 upstream-69c9cad2a1144523a6534a184064601e6cc8d48c.zip |
[buildroot] Implement an ARCH_PACKAGES variable which defaults to BOARD but can be overridden on a per-subtarget basis.
This is intended for targets such as adm5120 and malta which support both big and little endianess and will replace
the target specific exceptions in package-defaults and Image Builder.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23029 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -31,6 +31,7 @@ strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1)) _SINGLE=export MAKEFLAGS=$(space); CFLAGS:= ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH))))) +ARCH_PACKAGES:=$(call qstrip,$(CONFIG_TARGET_ARCH_PACKAGES)) BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD)) TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION)) TARGET_SUFFIX=$(call qstrip,$(CONFIG_TARGET_SUFFIX)) |