aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-13 17:41:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-13 17:41:02 +0000
commit4c63b791b6a6ec5f8646a6d397840573c34af207 (patch)
tree5cd068c1fdbd391339e2b9b1da877c7d54f93c06 /rules.mk
parent7d7e377ed93d6e72128ee50f1fc5d85acd709d81 (diff)
downloadupstream-4c63b791b6a6ec5f8646a6d397840573c34af207.tar.gz
upstream-4c63b791b6a6ec5f8646a6d397840573c34af207.tar.bz2
upstream-4c63b791b6a6ec5f8646a6d397840573c34af207.zip
fix whitespace order in cflags without CONFIG_DEBUG to prevent breakage in some packages' configure step
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12601 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 0e4c7f2905..614feb6fc5 100644
--- a/rules.mk
+++ b/rules.mk
@@ -64,7 +64,7 @@ TARGET_DIR:=$(BUILD_DIR)/root-$(BOARD)
IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/ipkg
TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(STAGING_DIR_HOST)/bin:$(STAGING_DIR)/host/bin:$(PATH)
-TARGET_CFLAGS:=$(TARGET_OPTIMIZATION) $(if $(CONFIG_DEBUG),-g3)
+TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3)
TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
TARGET_LDFLAGS:=-L$(TOOLCHAIN_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib