aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-06 00:56:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-06 00:56:36 +0000
commit5454f020e06477c1a3abf6876f11356546429703 (patch)
tree481964c42b60e52fe242bd73b2bad0f9067c3a65 /rules.mk
parent648d17f2e7f3b33ec59fb41a9817d8af0d014ba9 (diff)
downloadupstream-5454f020e06477c1a3abf6876f11356546429703.tar.gz
upstream-5454f020e06477c1a3abf6876f11356546429703.tar.bz2
upstream-5454f020e06477c1a3abf6876f11356546429703.zip
fix overzealous kmod stripping - it killed kernel module parameters (#1301)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6271 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 42e9978591..b63fcf31c8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -88,7 +88,7 @@ TARGET_CONFIGURE_OPTS:= \
# strip an entire directory
RSTRIP:= \
STRIP="$(STRIP)" \
- STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
+ STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment -w -K '__mod*'" \
$(SCRIPT_DIR)/rstrip.sh
# where to build (and put) .ipk packages