aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-23 14:03:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-23 14:03:03 +0000
commit86605d34c42ebc77651cdd1c757ba103da00f3fd (patch)
tree53896bc9a9990d82b0e7d5754561a37b04195060 /rules.mk
parent38af2ad2e29b03fecc0111fb02a1299799846605 (diff)
downloadupstream-86605d34c42ebc77651cdd1c757ba103da00f3fd.tar.gz
upstream-86605d34c42ebc77651cdd1c757ba103da00f3fd.tar.bz2
upstream-86605d34c42ebc77651cdd1c757ba103da00f3fd.zip
build: add -Wno-error=unused-result to target cflags
Many glibc functions have __warn_unused_result__ in so many different core functions, and failing the build for all of those simply does not make any sense Signed-off-by: Felix Fietkau <nbd@openwrt.org> Backport of r47440 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47607 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index e13d8ccc9f..9d0134d2b2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -143,7 +143,7 @@ ifndef DUMP
-include $(TOOLCHAIN_DIR)/info.mk
export GCC_HONOUR_COPTS:=0
TARGET_CROSS:=$(if $(TARGET_CROSS),$(TARGET_CROSS),$(OPTIMIZE_FOR_CPU)-openwrt-linux$(if $(TARGET_SUFFIX),-$(TARGET_SUFFIX))-)
- TARGET_CFLAGS+= -fhonour-copts $(if $(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),,-Wno-error=unused-but-set-variable)
+ TARGET_CFLAGS+= -fhonour-copts $(if $(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),,-Wno-error=unused-but-set-variable) -Wno-error=unused-result
TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/usr/include -I$(TOOLCHAIN_DIR)/include
TARGET_LDFLAGS+= -L$(TOOLCHAIN_DIR)/usr/lib -L$(TOOLCHAIN_DIR)/lib
TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(TARGET_PATH)