aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 15:30:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 15:30:50 +0000
commit77acae652fa5607fc76b07ce3ce558e8a845de30 (patch)
tree6156097aa76c3eb354e5af3e97c1857f2acf998a /rules.mk
parent443d4b872619902bb2457c5e2dbdb9e9786a9b14 (diff)
downloadupstream-77acae652fa5607fc76b07ce3ce558e8a845de30.tar.gz
upstream-77acae652fa5607fc76b07ce3ce558e8a845de30.tar.bz2
upstream-77acae652fa5607fc76b07ce3ce558e8a845de30.zip
add support for a common shell include file, which is evaluated for every make shell call, simplify variable passing to the shell with shvar and shexport templates, use Package/<pkgname>/config for adding config.in data
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5014 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/rules.mk b/rules.mk
index 84163ba225..8e5294edb3 100644
--- a/rules.mk
+++ b/rules.mk
@@ -8,8 +8,7 @@
-include $(TOPDIR)/.config
include $(TOPDIR)/include/verbose.mk
-export SHELL=/bin/bash
-
+export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))
WGET:=$(strip $(subst ",, $(CONFIG_WGET)))