aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 13:25:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 13:25:18 +0000
commit58e3b95a2c1565981cbcd642ae5b3f8e8c0178b9 (patch)
treecc3956e3b9776dd89f2577b09289a8ec2c9655cc /rules.mk
parent3bef21bbc8621d894d1c2d3d3e5163c09bf72155 (diff)
downloadupstream-58e3b95a2c1565981cbcd642ae5b3f8e8c0178b9.tar.gz
upstream-58e3b95a2c1565981cbcd642ae5b3f8e8c0178b9.tar.bz2
upstream-58e3b95a2c1565981cbcd642ae5b3f8e8c0178b9.zip
move certain host related variables to .host.mk generated by include/host-build.mk to speed up the build system
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5012 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk15
1 files changed, 0 insertions, 15 deletions
diff --git a/rules.mk b/rules.mk
index 0ec5daf086..84163ba225 100644
--- a/rules.mk
+++ b/rules.mk
@@ -64,21 +64,6 @@ ifneq ($(CONFIG_CCACHE),)
TARGET_CC:= ccache $(TARGET_CC)
endif
-HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
- -e 's/sparc.*/sparc/' \
- -e 's/arm.*/arm/' \
- -e 's/m68k.*/m68k/' \
- -e 's/ppc/powerpc/' \
- -e 's/v850.*/v850/' \
- -e 's/sh[234]/sh/' \
- -e 's/mips-.*/mips/' \
- -e 's/mipsel-.*/mipsel/' \
- -e 's/cris.*/cris/' \
- -e 's/i[3-9]86/i386/' \
- )
-
-GNU_HOST_NAME:=$(shell $(HOSTCC) -dumpmachine)
-
TARGET_CONFIGURE_OPTS:= \
AR=$(TARGET_CROSS)ar \
AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \