aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-03-06 11:02:08 +0000
committerNicolas Thill <nico@openwrt.org>2005-03-06 11:02:08 +0000
commit3d1af731a6291ec1c845e5280f1f5bfd00a95b91 (patch)
tree7d0bf0e9093d57535602a4672834925e5eb9d94a /rules.mk
parent30669cd9be45c062f98f8d2ce45a7f361a81a767 (diff)
downloadupstream-3d1af731a6291ec1c845e5280f1f5bfd00a95b91.tar.gz
upstream-3d1af731a6291ec1c845e5280f1f5bfd00a95b91.tar.bz2
upstream-3d1af731a6291ec1c845e5280f1f5bfd00a95b91.zip
Change ipkg invocation and add -force-defaults option
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@313 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 681d4f9b1c..4218bbf1b2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -112,7 +112,8 @@ endif
# invoke ipkg with configuration in $(STAGING_DIR)/etc/ipkg.conf
-IPKG := PATH="$(TARGET_PATH)" IPKG_CONF_DIR=$(STAGING_DIR)/etc ipkg -force-depends
+IPKG := IPKG_CONF_DIR=$(STAGING_DIR)/etc $(TARGET_DIR)/bin/ipkg -force-defaults -force-depends
+IPKG_STATE_DIR := $(TARGET_DIR)/usr/lib/ipkg
# invoke ipkg-build with some default options
IPKG_BUILD := PATH="$(TARGET_PATH)" ipkg-build -c -o root -g root