aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-12-02 12:20:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-12-02 12:20:34 +0000
commit0e9a69f081a7ac81e49efd3ceef6ca751443870f (patch)
tree5c2da9fe9f7f317a227399c73ad7e0b78482f2cb /rules.mk
parent187d283f6d4b5eb76e598f40b75287a768291b28 (diff)
downloadupstream-0e9a69f081a7ac81e49efd3ceef6ca751443870f.tar.gz
upstream-0e9a69f081a7ac81e49efd3ceef6ca751443870f.tar.bz2
upstream-0e9a69f081a7ac81e49efd3ceef6ca751443870f.zip
rules.mk: provide a macro "file_copy" which removes any symlink in the destination dir that would be overwritten
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34437 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 36bd22cac7..7139f79ef8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -287,6 +287,24 @@ define locked
-c '$(subst ','\'',$(1))'
endef
+# Recursively copy paths into another directory, purge dangling
+# symlinks before.
+# $(1) => File glob expression
+# $(2) => Destination directory
+define file_copy
+ for src_dir in $(sort $(foreach d,$(wildcard $(1)),$(dir $(d)))); do \
+ ( cd $$src_dir; find -type f -or -type d ) | \
+ ( cd $(2); while :; do \
+ read FILE; \
+ [ -z "$$FILE" ] && break; \
+ [ -L "$$FILE" ] || continue; \
+ echo "Removing symlink $(2)/$$FILE"; \
+ rm -f "$$FILE"; \
+ done; ); \
+ done; \
+ $(CP) $(1) $(realpath $(2)/)/
+endef
+
# file extension
ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1)))