aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-09-09 21:35:42 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-09-09 21:35:42 +0000
commit9c8ed9e702069fe9f826bfecba70352aea0d84f5 (patch)
tree256413a6045d50136147e5f1e52eb01a20233251 /rules.mk
parent14d4c6fe56a3f7b1524d15cc03565196f0fdcc95 (diff)
downloadupstream-9c8ed9e702069fe9f826bfecba70352aea0d84f5.tar.gz
upstream-9c8ed9e702069fe9f826bfecba70352aea0d84f5.tar.bz2
upstream-9c8ed9e702069fe9f826bfecba70352aea0d84f5.zip
[buildroot] do not pass optimization flags in HOST_CPPFLAGS (#12153)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33351 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index b7bad1ca54..995852e09b 100644
--- a/rules.mk
+++ b/rules.mk
@@ -173,7 +173,8 @@ PKG_CONFIG:=$(STAGING_DIR_HOST)/bin/pkg-config
export PKG_CONFIG
HOSTCC:=gcc
-HOST_CFLAGS:=-O2 -I$(STAGING_DIR_HOST)/include
+HOST_CPPFLAGS:=-I$(STAGING_DIR_HOST)/include
+HOST_CFLAGS:=-O2 $(HOST_CPPFLAGS)
HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib
TARGET_CC:=$(TARGET_CROSS)gcc