aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-07-28 21:06:59 +0000
committerJohn Crispin <blogic@openwrt.org>2012-07-28 21:06:59 +0000
commit7c4db9ed3837843a989f0040fe62e80246501b77 (patch)
tree60f4824aaa03a29ef8020a2a2c83ad8bad82ff86 /rules.mk
parent841bbe2dbd9e7b838351898c3494c06b44a55b6e (diff)
downloadupstream-7c4db9ed3837843a989f0040fe62e80246501b77.tar.gz
upstream-7c4db9ed3837843a989f0040fe62e80246501b77.tar.bz2
upstream-7c4db9ed3837843a989f0040fe62e80246501b77.zip
[include] fix up scons vs ccache
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32902 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk13
1 files changed, 7 insertions, 6 deletions
diff --git a/rules.mk b/rules.mk
index 412615c320..114b16ce3a 100644
--- a/rules.mk
+++ b/rules.mk
@@ -185,13 +185,14 @@ INSTALL_DIR:=install -d -m0755
INSTALL_DATA:=install -m0644
INSTALL_CONF:=install -m0600
+TARGET_CC_NOCACHE:=$(TARGET_CC)
+TARGET_CXX_NOCACHE:=$(TARGET_CXX)
+HOSTCC_NOCACHE:=$(HOSTCC)
+export TARGET_CC_NOCACHE
+export TARGET_CXX_NOCACHE
+export HOSTCC_NOCACHE
+
ifneq ($(CONFIG_CCACHE),)
- TARGET_CC_NOCACHE:=$(TARGET_CC)
- TARGET_CXX_NOCACHE:=$(TARGET_CXX)
- HOSTCC_NOCACHE:=$(HOSTCC)
- export TARGET_CC_NOCACHE
- export TARGET_CXX_NOCACHE
- export HOSTCC_NOCACHE
TARGET_CC:= ccache_cc
TARGET_CXX:= ccache_cxx
HOSTCC:= ccache $(HOSTCC)