aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-06 16:01:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-06 16:01:06 +0000
commit6683f47568f53d23b743ccc9e7ece22851542ec3 (patch)
treefc4fa7e354f89168dfef355257fe96bb8c5be74a /rules.mk
parentfc96ba7411576da2232cf2cb7122c6440f3b8122 (diff)
downloadupstream-6683f47568f53d23b743ccc9e7ece22851542ec3.tar.gz
upstream-6683f47568f53d23b743ccc9e7ece22851542ec3.tar.bz2
upstream-6683f47568f53d23b743ccc9e7ece22851542ec3.zip
build: rework the package/install step - collect package install lists during package/compile, then install all packages at once
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33631 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index e657eec791..34c86ca49c 100644
--- a/rules.mk
+++ b/rules.mk
@@ -105,6 +105,7 @@ TARGET_ROOTFS_DIR?=$(if $(call qstrip,$(CONFIG_TARGET_ROOTFS_DIR)),$(call qstrip
TARGET_DIR:=$(TARGET_ROOTFS_DIR)/root-$(BOARD)
STAGING_DIR_ROOT:=$(STAGING_DIR)/root-$(BOARD)
BUILD_LOG_DIR:=$(TOPDIR)/logs
+PKG_INFO_DIR := $(STAGING_DIR)/pkginfo
TARGET_PATH:=$(STAGING_DIR_HOST)/bin:$(subst $(space),:,$(filter-out .,$(filter-out ./,$(subst :,$(space),$(PATH)))))
TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3)