aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-02-20 17:38:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-02-20 17:38:26 +0000
commit32a69747812d72bb93bd3a71090d5db58b9a5602 (patch)
treec955963e3b6883779c13612d6ca114ff500ab4f8 /rules.mk
parent31df1c58cb4a9c1da3bb67e7d5cd3bc9b2839799 (diff)
downloadupstream-32a69747812d72bb93bd3a71090d5db58b9a5602.tar.gz
upstream-32a69747812d72bb93bd3a71090d5db58b9a5602.tar.bz2
upstream-32a69747812d72bb93bd3a71090d5db58b9a5602.zip
strip kernel modules more aggressively: make all global symbols local, rename all symbols in the symbol table to make them compress better
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30662 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 474c0e2461..79a2a9fa48 100644
--- a/rules.mk
+++ b/rules.mk
@@ -219,9 +219,10 @@ else
endif
endif
RSTRIP:= \
+ export CROSS="$(TARGET_CROSS)"; \
NM="$(TARGET_CROSS)nm" \
STRIP="$(STRIP)" \
- STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded -R .comment -R .pdr -R .mdebug.abi32 -R .note.gnu.build-id -R .gnu.attributes -R .reginfo -x" \
+ STRIP_KMOD="$(SCRIPT_DIR)/strip-kmod.sh" \
$(SCRIPT_DIR)/rstrip.sh
endif