aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-07-31 22:32:21 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-07-31 22:32:21 +0000
commitef5dc72b5cb05731045fa0b7c8125500c8e65f44 (patch)
tree7e126c03b0c762030848d9bb6fb238f4232c0c3b /rules.mk
parente6131cac2b9459e99bc324e6036c5b26db1b6ee3 (diff)
downloadupstream-ef5dc72b5cb05731045fa0b7c8125500c8e65f44.tar.gz
upstream-ef5dc72b5cb05731045fa0b7c8125500c8e65f44.tar.bz2
upstream-ef5dc72b5cb05731045fa0b7c8125500c8e65f44.zip
[buildroot] fix for GREP_OPTIONS
When using GREP_OPTIONS to supply default options to grep, the buildsystem might get broken (For example adding --color=always breaks it) This patch will empty the GREP_OPTIONS to prevent the described (and any other) problems related to GREP_OPTIONS Signed-off-by: Maarten Bezemer <m.m.bezemer@utwente.nl> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22443 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 0cb72ac6bc..2add087133 100644
--- a/rules.mk
+++ b/rules.mk
@@ -18,6 +18,9 @@ TMP_DIR:=$(TOPDIR)/tmp
export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
+GREP_OPTIONS=
+export GREP_OPTIONS
+
qstrip=$(strip $(subst ",,$(1)))
#"))