aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-05 20:26:14 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-05 20:26:14 +0000
commit993c51d83d26e8a18e54de0b0074448a0e5113f8 (patch)
tree9252e4f0a78a4bbb4e2f438c47d19006460fcf3b /rules.mk
parent86c9f602a76b66d0dfd017c3f851783378ce2c87 (diff)
downloadupstream-993c51d83d26e8a18e54de0b0074448a0e5113f8.tar.gz
upstream-993c51d83d26e8a18e54de0b0074448a0e5113f8.tar.bz2
upstream-993c51d83d26e8a18e54de0b0074448a0e5113f8.zip
there are quite a lot of package using ln -sf in their Makefile, so
this patch adds LN:=ln -sf to rules.mk -Raphael git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19998 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 942c7b416f..a7d7a34d55 100644
--- a/rules.mk
+++ b/rules.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -142,6 +142,7 @@ TARGET_CXX:=$(if $(CONFIG_INSTALL_LIBSTDCPP),$(TARGET_CROSS)g++,no)
PATCH:=$(SCRIPT_DIR)/patch-kernel.sh
SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
CP:=cp -fpR
+LN:=ln -sf
INSTALL_BIN:=install -m0755
INSTALL_DIR:=install -d -m0755