aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-10-31 15:33:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-10-31 15:33:48 +0000
commit80a0951f3f3116b1ed2b0868e38a9a937413bbe5 (patch)
tree21630864d1da67dadb565dee0daf83f47091b5b0 /rules.mk
parent30453b2e5e03d3b81845473d6c7716ff3092100a (diff)
downloadupstream-80a0951f3f3116b1ed2b0868e38a9a937413bbe5.tar.gz
upstream-80a0951f3f3116b1ed2b0868e38a9a937413bbe5.tar.bz2
upstream-80a0951f3f3116b1ed2b0868e38a9a937413bbe5.zip
fix usage of flock - use the command mode instead of locking a file descriptor to fix build issues on mac os x
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23743 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/rules.mk b/rules.mk
index 007e5bc9b2..3bd6073fb7 100644
--- a/rules.mk
+++ b/rules.mk
@@ -254,9 +254,10 @@ endef
# $(2) => The lock name. If not given, the global lock will be used.
# $(3) => The filedescriptor used for the lock. Defaults to 1023.
define locked
- ( $(STAGING_DIR_HOST)/bin/flock -x $(if $(3),$(3),1023) && \
- $(1) \
- ) $(if $(3),$(strip $(3)),1023)>$(TMP_DIR)/.$(if $(2),$(strip $(2)),global).flock
+ SHELL= \
+ $(STAGING_DIR_HOST)/bin/flock \
+ $(TMP_DIR)/.$(if $(2),$(strip $(2)),global).flock \
+ -c '$(subst ','\'',$(1))'
endef
# file extension