aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-01-15 11:43:13 +0000
committerJohn Crispin <blogic@openwrt.org>2012-01-15 11:43:13 +0000
commit1e0b48fafb133310de5e166adaf0c3957e7bee05 (patch)
tree5e1b24560a28f3d1faf6dc571355446688ffcdaa /rules.mk
parent8f76568da91dbe989e5365a4a6d3f50847b1c755 (diff)
downloadupstream-1e0b48fafb133310de5e166adaf0c3957e7bee05.tar.gz
upstream-1e0b48fafb133310de5e166adaf0c3957e7bee05.tar.bz2
upstream-1e0b48fafb133310de5e166adaf0c3957e7bee05.zip
tools: clean up Makefiles / make ccache work
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29754 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 53891eaa97..ef61c4d749 100644
--- a/rules.mk
+++ b/rules.mk
@@ -170,6 +170,7 @@ PKG_CONFIG:=$(STAGING_DIR_HOST)/bin/pkg-config
export PKG_CONFIG
HOSTCC:=gcc
+HOSTCC_NOCACHE:=$(HOSTCC)
HOST_CFLAGS:=-O2 -I$(STAGING_DIR_HOST)/include
HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib
@@ -188,6 +189,7 @@ INSTALL_CONF:=install -m0600
ifneq ($(CONFIG_CCACHE),)
TARGET_CC:= ccache $(TARGET_CC)
TARGET_CXX:= ccache $(TARGET_CXX)
+ HOSTCC:= ccache $(HOSTCC)
endif
TARGET_CONFIGURE_OPTS = \